Fork me on GitHub

flutter - android studio 环境配置问题

建议不改动安装的相关资源位置。不然会多处一些异常问题。

grade 无法载入

修改配置文件:

  1. 【当前项目】> android > build.grade
  2.  ~flutter\packages\flutter_tools\gradle\flutter.gradle

找到配置文件中 buildscript.repositories & allprojects.repositories。 删除 括号内的原有内容,并修改为阿里云镜象。

buildscript {
    repositories {
// google()
// jcenter()
        maven { url 'https://maven.aliyun.com/repository/google' }
        maven { url 'https://maven.aliyun.com/repository/jcenter' }
        maven { url 'http://maven.aliyun.com/nexus/content/groups/public' }
    }
}

allprojects {
    repositories {
// google()
// jcenter()
        maven { url 'https://maven.aliyun.com/repository/google' }
        maven { url 'https://maven.aliyun.com/repository/jcenter' }
        maven { url 'http://maven.aliyun.com/nexus/content/groups/public' }
    }
}

模拟器无法正常运行

错误提示 emulation currently requires hardware acceleration

双击运行 ~\AppData\Local\Android\Sdk\extras\intel\Hardware_Accelerated_Execution_Manager\intelhaxm-android.exe

安装成功后,模拟器可以运行。